Forum-mercedes.com

Le forum 100% non officiel et indépendant des passionnés Mercedes-Benz

Vous n'êtes pas identifié(e).     

Annonce

#26 07-06-2022 10:14:06

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

En fait je n'ai pas de problème, mon codage fonctionne bien.
C'est pas impossible qu'à partir d'une certaine date, certaines fonctions ont évolué, ce qui expliquerait que pour certains ils n'ont pas à pousser le comodo. Pour la mise à jour, je penserais plutôt à la camera, mais bon, ça veut dire recalibrage etc...
Bref, ce n'est plus vraiment mon souci, puisque dans ma cave j'ai des optiques Multibeams qui attendent d'être montés, depuis plus de 6 mois. J'avais déjà fait le test de les brancher sans quasiment rien demonter (je me suis fait un faisceau électrique intermediaire), ça fonctionne).
Mon souci actuellement pour finaliser (en plus du temps), c'est au niveau de la bite à pré-fusibles, comme je l'ai indiqué sur => ce post >=, j'ai peur de casser quelque chose en le démontant. Mais bon, je suis plus à 1 mois prés.. Bientôt ma revision en concession..


A200 W177 - Progressive Line

Hors Ligne

Annonce

#27 07-06-2022 19:31:33

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

J'ai mis à jour la caméra multifonctions pour pouvoir coder la mémoire du lane assist, je n'ai pas eu à re calibrer la caméra.

Et non ce n'est pas celui-ci qui gère les feux automatiques, c'est le BCMFA2 que tu dois mettre à jour. Et (ça fait beaucoup de et lol ), ton codage est bon, en effet.

EDIT : je ne peux pas t'aider pour ton post sans réponse. C'est pour ça que je n'ai pas répondu d'ailleurs lol

Dernière modification par Flo354 (07-06-2022 19:32:04)


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#28 07-06-2022 20:15:48

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

Hmmm, mais pourquoi un faisceau intermédiaire au juste et pourquoi démonter ça ?

Tu n'as qu'à connecter ton fil du 12V et celui de la masse aux fils qui alimentent déjà le premier calculateur.


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#29 07-06-2022 20:47:05

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Un faisceau intermédiaire pour tester sans rien démonter. Dans mon cas, à partir des Leds Highbeam il n'y a qu'un + et 1 - à ajouter à chaque optique oui, mais il y a aussi une inversion à faire par rapport à l'existant, et la longueur disponible m'aurait sans doute empêché de pouvoir poser (temporairement) les feux où je le voulais.
Bon, par chance j'ai déjà les capteurs de niveau, c'est ça de gagné. D'ailleurs je me demande si ça peut fonctionner sans ces capteurs ?

Ce qui me chagrine, c'est comment démonter ce boitier pré-fusibles sans rien casser hmm. Pour le test je m'étais arrangé de façon + simple, mais pour le définitif je veux le faire comme il faut, et être bien prêt avant de démonter le pc. En plus j'ai des doutes sur le type de connecteur nécessaire pour se raccorder dans cette boite sad

Bref, sacrée histoire ces multibeams (que de péripéties rien que pour l'achat déjà… je pourrais écrire un roman mdr)

et merci pour l'info du recalibrage de la camera pas necessaire, du coup je vais  voir de la mettre à jour pour avoir cette ligne qui me manque actuellement (lastmode lane assist). En tous cas, j'avais eu à y toucher pour le 608

Dernière modification par Lain13 (07-06-2022 20:54:00)


A200 W177 - Progressive Line

Hors Ligne

#30 07-06-2022 21:16:50

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

Ok je comprends pour le faisceau intermédiaire. Mais pour le final, tu n'as pas besoin de démonter le boîtier pré-fusible. Tu peux directement le faire avec le câblage existant. Tu fais ton inversion, tu rajoutes ton fil +12v, ton fil de GND.

Tu ouvres la gaine de câblage et tu connectes le +12v à l'alimentation +12v déjà présente pour le calculateur 1, et le GND au GND du calculateur 1.

Ça fonctionne impec comme ça !


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#31 07-06-2022 22:14:04

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Oui, mais non:
chaque Highbeam utilisant 1 seul positif, les optiques AV gauche et AV droit utilisent chacun un fusible différent.
chaque multibeam utilise 2 positifs et chacun 2 fusibles différents.
A la limite je mixerai les nouvelles et anciennes GND pour chaque optique sur la même masse dans le moteur, mais pas tres chaud pour les 2 + du même optique sur un même fusible. Si j'ai bien compris ce que tu voulais dire.

Tiens, un truc rigolo: quand j'ai fait mon test, le soir même je recevais une notification de Mercedes Me me signalant un souci avec les optiques.


A200 W177 - Progressive Line

Hors Ligne

#32 08-06-2022 06:49:33

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

J'ai eu un retrofit multibeams à coder, la personne avait fait comme ça et c'était passé nickel.

Après, c'est peut-être pas dans les règles de l'art absolues mais ça fonctionne.

Pour le défaut, ben alors je peux te dire que j'ai eu le même le lendemain. Le message était : code gauche défaut.

Du coup j'ai désactivé le telediagnostique ainsi que le diagnostic à distance. De toutes façons ce n'est pas pertinent pour nous qui avons les outils de diag.


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#33 08-06-2022 07:50:50

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Tiens en parlant de télédiagnostic, j'ai reçu une invitation hier pour mon futur service, pour 0 euro (mon contrat a bien été pris en compte).
Dans ce rappel il y avait notamment le kilométrage exact du véhicule.

Pour les fusibles, outre l'ampérage sans doute légèrement diffèrent, c'est peut être pour une raison de sécurité de ne pas mettre chaque optique sur un seul fusible. Apres, mon expérience en bureau d'études font peut être que je suis plus pointilleux sad

Du coup, va falloir que je trouve une solution pour ce boitier..


A200 W177 - Progressive Line

Hors Ligne

#34 08-06-2022 17:46:14

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

Je repense à mon installation des Multibeams. Le câblage c'est Kufatec qui l'avait fait. D'ailleurs ils s'étaient trompés dans les PINs et du coup on avait dû revoir le schéma ensemble pour qu'ils m'envoient un nouveau câblage lol

Bref, je ne me rappelle pas combien j'ai mis de fusibles, mais en tout cas, je n'ai pas eu à démonter ce module. Tu rates forcément quelque chose à un endroit. Car dans mon cas, je devais carrément changer le câblage, vu que les halogènes sont branchés sur le SAM alors que les Multibeams c'est un bus CAN (avec les alimentations bien sûr en plus). Et pas de problématique de boîte à fusibles.

EDIT : de mémoire, branchement sur le CAN sous la boîte à gants, branchement sur les connectiques des phares, branchement du/des fusible(s)

Dernière modification par Flo354 (08-06-2022 17:47:50)


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#35 08-06-2022 20:30:38

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Bah j'ai les schémas et j'ai fait les faisceaux rallonge avec, et ça fonctionne. Mon faisceau fait d'ailleurs l'inversion de pin (9 <-> 7) pour le phare droit, sans toucher à ma fiche existante. cool

Chez Kufatec si tu prends un faisceau pour Highbeam l'inversion n'est pas faite, c'est normal. C'est différent du MultiBeam (où il faut aussi ajouter des fils "+" et "Gnd"). C'est cool de leur part s'ils t'ont renvoyé le bon faisceau. cool

Donc:
Coté alimentation (+12V) :
je confirme que les 2 fils rouge/jaune et rouge/bleu sont sur les 2 fusibles 20A du boitier coté moteur (f22 et f48 pour les feux Leds Highbeam et Multibeam, mais 1 seul et unique 5A (f64) pour les halogènes, au même endroit coté moteur.
Pour moi (HighBeam <-> MultiBeam) je n'ai aucun fusible à ajouter.
En venant de feux halogènes en revanche, il ne faut plus utiliser le fusible de 5A (mais les 2 x 20A), c'est ce que tu as dû faire.

Coté transit des data (le bus CAN) :
En cas de feux halogènes (ton cas il me semble), il n'y a aucune liaison au bus CAN. C'est aussi certainement celle(s) que tu as dû ajouter, pour aller sous la boite à gants, sur le connecteur X30/27.
Au passage : à moins que tu aies aussi ajouté les capteurs de niveau sur les essieux AV + AR (?), je ne vois pas quelle info peut transiter via le bus. roll Ton éclairage d'angle fonctionne bien ?

Sur ma voiture, ils sont déjà présents de par les Highbeam, mais aussi grâce au code 459, où ils sont utilisés pour la suspension adaptative. Les mêmes capteurs sont donc aussi utilisés pour les feux à Led (High et aussi Multibeam).
Donc j'ai juste les 2 liaisons +12V (et les 2 masses) pour chaque côté, à ajouter sur les fusibles déjà existants.

Je vois pas ce que j'ai pu manquer ?
Et je n'ai pas la référence du type de connecteur à utiliser pour raccorder le nouveau +12V.
Mais un jour, j'arriverai à démonter pour voir, ou alors faut que je me renseigne mieux.

smile


A200 W177 - Progressive Line

Hors Ligne

#36 08-06-2022 21:25:10

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

Je n'ai pas rajouté les capteurs de niveau. Pour le bus CAN, il faut bien couper les LEDs qui vont en direction de la voiture d'en face. Les HLI_FL et HLI_FR communiquent avec la caméra multifonctions (entre autres).

Pour l'éclairage d'angle, tu veux parler de la lumière qui s'allume quand on prend un virage ? Si tu parles de ça, oui ça fonctionne.

Je viens de poser la question à un ami, il me dit "ça ne sert à rien de s'embêter à aller sur d'autres fusibles et faire un montage particulier. Dis-lui de mettre le +12V et le GND sur la même alimentation et ça passe nickel"

Du coup je ne peux pas plus t'aider car je ne connais personne qui a démonté cette pièce.

P.S : Kufatec c'était trompé. J'avais commandé un câblage Multibeams. Ils m'avaient envoyé un cablage led high performance. Ils n'avaient pas vu que les Multibeams avaient une alim en plus donc ils avaient juste fait l'inversion.

Dernière modification par Flo354 (08-06-2022 21:26:18)


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#37 10-06-2022 12:31:35

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Bon du coup ce week end je tente la mise à jours des ecu camera et sam...

Pour le montage des multibeams ça attendra de toute façon apres la prochaine révision.


A200 W177 - Progressive Line

Hors Ligne

#38 10-06-2022 14:51:59

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

La mémoire du Lane Assist c'est la base !
Bon courage, la mise à jour de la caméra prend environ 20 / 30 minutes (passe par CAN)


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#39 10-06-2022 16:07:55

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Mouais bof je vais le faire pour le fun wink Le lastmode pour le start&stop a la limite c’est mieux et pas  besoin de mettre a jour quoi que ce soit. Pour le lane assist (meme si je mets mes clignotants), j’avais simplement desactive le coup de frein en ne gardant que la vibration dans le volant au cas ou.


A200 W177 - Progressive Line

Hors Ligne

#40 10-06-2022 19:48:19

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

On s'habitue trop à la mémoire du lane assist, tu vas voir lol


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#41 13-06-2022 09:21:15

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Bon, mises à jour des ecu smpc et bcmfa2:

smpc213: je suis passé de la version 820B à la version 820D mais apparemment il faudrait la 820F minimum. Vu le temps que ça prend etc.. faudra que je le fasse une prochaine fois. (Mais lastmdode activé, si je me souviens bien, mais non fonctionnel)
bcmfa2: là c'est plus compliqué , j'ai flashé une v13 et resultat: enormément d'erreurs car beaucoup de parametres manquants par rapport à l'ancien, donc retour à l'original (v8)

Du coup je me demande si les limites des versions matérielles de mes ecu ne vont pas me brider logiciellement. Pour le code 608 ca n'avait pas posé de problème, donc j'espère que pour le 628 non plus. Je ne sais pas avec certitude, le numéro de version maxi quii est supporté par ma version matérielle.

Au passage, durant mes flashages je n'avais pas raccordé le chargeur. A la fin j'ai fini par recevoir des alertes critiques pour la batterie 12V (emails etc..). Effectivement la batterie etait tombée à 40%. Alors je suis allé faire un (grand) tour et quand je suis rentré, la batterie etait à 85%. Bien sûr, le S&S fonctionne et l'appli ME affiche "Chargée". Ma batterie semble en bon etat, malgré son âge smile


A200 W177 - Progressive Line

Hors Ligne

#42 13-06-2022 16:51:10

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

On ne flashe pas le module SAM sans avoir connecté un chargeur de batterie lol
Tu nous l'a fait à la one again (ou plutôt, à la wanégaine) ! Tu as surtout de la chance qu'il fasse 500°C ces temps-ci.
S'il faisait -20°C ça n'aurait peut-être pas été la même lol


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#43 13-06-2022 17:51:40

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Ce qui m'a vidé la batterie, c'est pour la caméra. Pour le SAM no souci, c'est rapide, et je l'ai commencé avec 85% de charge. Au besoin, j'aurais branché le chargeur.
Et je me vois mal flasher par -20° mdr (si toutefois il peut faire -20 chez moi) lol mais c'est vrai que le chargeur est recommandé.
Bref, je retenterai la smpc avec un autre firmware que j'ai... Et pour le sam je crois que je vais laisser tomber, il y a tellement de versions différentes...

Dernière modification par Lain13 (13-06-2022 18:13:34)


A200 W177 - Progressive Line

Hors Ligne

#44 13-06-2022 18:19:48

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

Donne-moi pour les deux calculateurs :
- Hardware Number Part Information
- Software Number Part Information

Ils sont récupérés par DTS automatiquement quand tu te connectes dessus.

Je peux peut-être te trouver la révision adaptée


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#45 13-06-2022 19:47:21

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Voilà mes versions actuelles:

BCMFA2 (R8_):
HW: 247 901 78 01
SW: 247 902 18 01 (2479021801_001-SMR-20181217_1613.zip)

SMPC213 (var820D):
HW: 247 901 32 02
SW: 247 902 42 02 (2479024202_001-SMR-20190112_1935.zip

Pour la camera je compte tester directement le 2479027710_001-SMR-20201020_0810.zip (var810 à priori), voire la version var820F du 2479020603_001-SMR-20190612_0542.zip, qui devrait être la version minimum pour le lastmode du lane assist.

Pour le sam j'ai testé (mais avec trop d'écarts) le 2479022004_001-SMR-20191028_1348.zip (R_13), pour finalement revenir à l'original 2479021801_001-SMR-20181217_1613.zip (R_8)

Dernière modification par Lain13 (13-06-2022 21:44:10)


A200 W177 - Progressive Line

Hors Ligne

#46 14-06-2022 06:24:43

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

Je crois qu'on a même HW pour le SMPC213. Je suis en déplacement ce début de semaine. Dès que j'ai 5 minutes je regarde !


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#47 14-06-2022 07:03:08

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Ah si tu as la meme version hw que moi pour la camera (smpc213) alors ca me rassure (tu dois être au minimum en version sw var820F ? Je testerai un de ces jours les 2 fw qu’il me reste (ceux cités plus haut).
Pour le sam par contre il me semble qu’ils te l’avaient remplacé, donc version plus récente que le mien certainement ?


A200 W177 - Progressive Line

Hors Ligne

#48 15-06-2022 13:12:03

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

SW SMPC213 => 247 902 06 03 (Rev 820F)
SW BCMFA2 => 247 902 10 02 (Rev R_11) => Il faut que je mette à jour car il y a parfois un petit soucis avec cette version, une erreur bizarre dans le diag
SW HVAC177 => 247 902 13 02 (même hardware que BCMFA2) (Rev R_11)

P.S : non, mon SAM n'a pas été changé

Dernière modification par Flo354 (15-06-2022 13:14:47)


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

#49 15-06-2022 14:10:01

Lain13
Haut gradé à Montigny
Inscription : 06-10-2019
Messages : 2 142

Re : Feux à LEDs HighBeam (sans MultiBeam)

Ok, pour la camera j'utiliserai donc directement celui que j'ai sous le coude (820F), je tente pas le 8210.

Pour ton sam, si on a effectivement le même hw, chez moi la R_13 posait trop de problèmes.
Du coup, en lisant ce que tu dis de la R_11, je ne la tenterai sans doute pas.
Je sais pas s'il faudrait que je fasse R_9 puis R_10, puis R_11 etc... histoire de faire à chaque étape les modifs manuellement. C'est du boulot, et j'ai des doutes.
En tout cas, si tu tentes la R_12 et que ça règle tes soucis, c'est cool. Moi pour l'instant moi je n'y touche pas.

Sinon, pourquoi toucher au hvac ? (je regarderai quelle version hw j'ai)


A200 W177 - Progressive Line

Hors Ligne

Annonce

#50 15-06-2022 14:33:22

Flo354
Directeur
Lieu : 06 / 13
Inscription : 08-08-2020
Messages : 1 674

Re : Feux à LEDs HighBeam (sans MultiBeam)

Il y a deux SAM dans la voiture, j'ai remarqué sur les données que j'ai, les deux SAM ont toujours la même révision et le même HW.
Il n'y a pas besoin de faire de manière incrémentale. C'est comme le IC177 tu peux passer de la variante 010 à 068 en un seul coup ; il suffit juste de bien reconfigurer les paramètres à posteriori puisque tu ne peux pas faire de online.


Classe A220 2019 (W177) Blanche - Progressive Line - Essence - Boite Auto
MBUX FUP3

Hors Ligne

Annonce

Annonce


Pied de page des forums




Server Stats - [ Generated in 0.039 seconds ]   [ 2012 - 2022 Forum-mercedes.com ]  [ Design by Yuni ]