Calcul conso avec open.calc (Page 1) / Le café du coin / Forum-mercedes.com

Forum-mercedes.com

Le forum 100% non officiel et indépendant des passionnés Mercedes-Benz

Vous n'êtes pas identifié(e).     

Annonce

#1 17-07-2016 17:41:32

tonton412
Sans permis
Inscription : 10-07-2016
Messages : 10

Calcul conso avec open.calc

Bonjour à tous,
Avec ma nouvelle auto, je voudrais tenir un tableau de consommation carburant. Ci-dessous un exemple de tableau.
Je connais la formule pour calculer ligne par ligne (E4=C4*100/(B4-B3))
Mais je voudrais trouver une formule qui me calcule automatiquement la somme E en entrant simplement le kilométrage en B et le nombre de litres en C

160717065643721686.jpg

Merci d'avance à ceux qui pourront m'aider! smile

Dernière modification par tonton412 (17-07-2016 17:58:40)

Hors Ligne

Annonce

#2 17-07-2016 18:24:55

Nicolas78420
Technicien diagnostic
Inscription : 12-05-2016
Messages : 331

Re : Calcul conso avec open.calc

Avec ta logique ça donne ça :

Capture_20160717-1320.jpg

Les formules :

En C3 : =SI(B4>0;B4-B3;"") puis copier le formule dans toute la colonne
En F3 : =SI(B4>0;(D3/(B4-B3))*100;"") puis copier le formule dans toute la colonne

En G3 : =SOMME(D3:D500)/SOMME(C3:C500)*100

Tu peux masquer la colonne C, à chaque fois que tu entreras un km et un litrage, ça calculera la conso à la ligne et mettra à jour la conso moyenne.

Dernière modification par Nicolas78420 (17-07-2016 18:25:15)


E320 CDI Elegance 1999

Hors Ligne

#3 18-07-2016 21:20:12

tonton412
Sans permis
Inscription : 10-07-2016
Messages : 10

Re : Calcul conso avec open.calc

Bonjour,
J'ai eu aujourd'hui  (d'une secrétaire à mon bouleau) une réponse on ne peut plus simple:
en fait, il suffit simplement "d’attraper" le coin inférieur droit de la case E4 et de "tirer" vers le bas; et là, ça recalcule la formule sur les lignes suivantes. Trop simple! cool
Merci Nicolas78420 pour ta réponse que je n'ai pas parfaitement saisie; pas grave roll

Hors Ligne

#4 18-07-2016 22:02:25

Nicolas78420
Technicien diagnostic
Inscription : 12-05-2016
Messages : 331

Re : Calcul conso avec open.calc

Ah oui, j'avais pas compris que tu voulais simplement copier la formule dans les lignes du dessous parce que tu disais que tu savais le faire ligne par ligne.

Ce que je te propose c'est en plus du calcul ligne par ligne un calcul de consommation moyenne à partir de toutes les consommmations ligne par ligne.

Pour ça il faut calculer le kilometrage entre chaque pleins et pouvoir en faire la somme d'ou la colonne C. Il ne faut aussi afficher un résultat de calcul que si on peut calculer quelque chose de logique.

Donc la formule  =SI(B4>0;B4-B3;"") dit que si B4 est suppérieur à 0, alors on calcule B4-B3 et dans le cas contraire, on affiche rien. Le calcul s'inscrit directement comme B4-B3 alors que demander un affichage se met entre guillemets : Si je demande "ESSAI" la cellule affichera ESSAI et si je ne met rien entre les guillemets, la cellule n'affichera rien.

=SI(CONDITION;SI VRAI;SI FAUX)

Pour la consiommation moyenne, je prends la somme de tous les kilometrage divisé par la somme de tous les volumes en litre x 100

La formule =SOMME(D3:D500)/SOMME(C3:C500)*100 fait ça de la ligne 3 à la ligne 500 ou la possibilité de replir 497 lignes

Le résultat sera toujours en G3 et comme il prend la somme de toutes les lignes, à chaque fois que tu en entres une nouvelle il la prend en compte dans son calcul

Maintenant si la consommation moyenne ne t'intéresse pas ta feuille de calcul est ttrès bien wink


E320 CDI Elegance 1999

Hors Ligne

Annonce

Sujets similaires

Discussion Réponses Vues Dernier message
10 222 06-12-2016 19:26:56 par robigeo
E430 V8 et conso par Stones
1 44 02-12-2016 09:56:34 par Labetenoir
0 45 24-11-2016 16:22:39 par Mercedes-Benz France
0 54 21-11-2016 11:30:48 par Jolga56
2 136 18-11-2016 17:24:39 par benj04

Pied de page des forums




Server Stats - [ Generated in 0.048 seconds ]   [ 2012 - 2016 Forum-mercedes.com ]  [ Design by Yuni ]